0

I have begun my studies of the Chinese language and tried to set up my computer (which runs the Debian Stretch free operating system) to enable me to type Chinese characters. For that reason, I installed ibus and the auxiliary package "ibus-pinyin". Yet it seems as though I can't type Chinese characters that are more than three letters long. For instance, I can't type the Chinese character that represents "shìn", the word for "last name".

Fortunately, whenever the character has only three letters, my ibus works perfectly fine.

I've already tried replacing "ibus-pinyin" by "ibus-libpinyin", but this caused the pinyin option to disappear altogether. Moreover, I tried the command "ibus-daemon -drx", which has no effect whatsoever.

I understand that using the command "ibus-setup" (and subsequently clicking the right button a couple times) I obtain a window containing all sorts of options regarding pinyin. I've thus far been unable to locate the right option that does what I want. (A similar dialog also appears when I push the language button in my menu bar and then the "Preferences" button, which only appears when Chinese is the current input method.)

My computer language is French, but I'm using the German keyboard layout.

  • Sorry, I can't answer your question, but point you in another direction: I'm using fcitx (on Arch Linux). There should be a package for Debian as well, and I recommend you give it a try. – Philipp Jan 13 at 21:47
  • "shin" is not a valid pinyin, it should be "xing" – fefe Jan 14 at 1:53
  • I use ubuntu-ibus-cangjie every day. To reveal your problem, I installed ibus-pinyin. It did show some problem. I could not input 姓 by using xin, xing, shin or shing. I completely uninstalled ibus-pinyin, and installed ibus-libpinyin. It worked. Then, I completely uninstalled ibus-libpinyin, and installed ibus-pinyin again. It worked. The pinyin code of 姓 is xing. So, you can try to uninstall ibus-pinyin and/or ibus-libpinyin, (reboot your system, ) and then install one of them again. – user-487 Jan 14 at 6:59
0

Thank you, it transpired in the comments that I used the wrong shortkey; it should have been "xing", and now it works fine:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.