2

recently my Windows 10 was updated and with came some changes with the input methods that I was using, namely Google Chinese Piyin 谷歌拼音. The problem is that I cannot access it now for no clear reason. I could actually accept Microsoft Pinyin IME, as long as it could help me to one thing: change the default 【】 quotation marks, for 「」 that I have been using for years.

I have seen all the settings and did not find any function that could help me set up substitution characters as I was used in Google Pinyin IME.

Any ideas, guys? Patrik

4
1

1, You can use the software "Auto-hot-key"

Create a script and add the following lines

[::「
]::」

Run the scripts.

When you type [ on the keyboard it will be 「. When you type ] it will be 」. This solution will work regardless of Input Methods. This is neat and the most recommended solution.

You can also use different hotkeys, with or without modifiers, as you like. such as

^[::「
^]::」

means when you type ctrl + [ on the keyboard it will be「.

And if you are using 「」 as a Chinses counterpart of " " you can use the following script

+'::
 {
   toggle := !toggle
   if (toggle)
    {
      sendinput, 「
    }
   else
    {
      sendinput, 」
    }
 }
return

When you type Shift + ', it will send 「 and 」alternatively, same as when you are using the double quotes in English.

Auto-hot-key download and document link: https://www.autohotkey.com/

2, Here is an easy walk around that allows you to type 「」

Open MS PinYin settings, and choose Lexicon and self-learning enter image description here

Choose add or edit existing user-defined phrase enter image description here

Add the following phrase enter image description here

Then type enter image description here

No additional software, but need some setup.

3, MS Pinyin Trick

When using MS Pinyin, type uubd, you will find the one you need. Maybe you need to press "+" a few times to find them though. This solution needs no setup.

enter image description here

0

If you don't care about privacy, ads, and adwares, but have concerns about input speed and long-sentence input, use Sogou Pinyin.
Otherwise, Rime is your only option. It's very complex and difficult to setup, and can't input a whole sentence without multiple selections.

0
  1. Switch to Chinese input mode.
  2. right click the 中 icon
  3. In the General setting page, scroll down to find 'use English punctuation in Chinese mode'

By the way, in Key settings, select shift to switch Chinese/English, in Candidate navigation, select all to have a better experience.

Or,you can try the 手心输入法 http://www.xinshuru.com/

1
  • The PO is asking about 「」, not [ ]. – River Jan 5 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.