I am on a Windows 10 PC. I have installed the Zhengma method on RIME and have been using it for the past few months. But I want to try practicing with Shuangpin (aka Double Pinyin) since its easier on my hands when I type long sentences.


I installed Shuangpin but when I type, for example, JM > Jian ( which means sword), most Simplified characters come up, such as 剑 (instead of ). I have to scroll endlessly to get to the Traditional Character for 剑.

How do I go about making the Traditional Characters a priority ?

  • Do you have thr traditional Chinese fonts installed in your PC? Does the program allow you to choose the type of font to be displayed?
    – r13
    Commented Jan 17, 2023 at 0:19
  • Yes, I can type just fine with the shape-based input IME called Zhengma. I use RIME instead of Windows built-in IME. Commented Jan 17, 2023 at 0:39
  • Check your virtual keyboard to see whether it can switch between 繁體(注音)或簡體(拼音)input, the vocabulary style will change.
    – r13
    Commented Jan 17, 2023 at 1:01
  • I can switch between the keyboards. I can type but I think this dictionary isn't any good or I just don't know how to switch to Traditional Characters. Commented Jan 17, 2023 at 17:40

2 Answers 2


I'm not familiar with the version on Windows, but for Rime in general, press ctrl + ` (the key left to 1), it allows you to change input schema and settings for the current schema. From there you press 2, leading you to the settings for the current schema. If the current schema allows, you can switch simplified and traditional Chinese there.

  • Thanks ! I didn't know I could switch schemas through CTRL+`.Very useful. I am just trying to learn how to get a better dictionary for Shuangpin and how to install it in RIME because most things only show up in Simplified. Commented Jan 17, 2023 at 17:23

Okay, what happened was, RIME was holding old data anytime I made a change to the settings or any external files associated with the RIME.

My problem was that anytime I typed a sentence, RIME would pull up Simplified characters the majority of the time so it became a hassle to go and look for the Traditional Characters.

I am now using RIME WITH TRADITIONAL CHARACTERS with Shuangpin successfully (using the luna_pinyin dictionary :) ).

For anyone wondering, I removed RIME entirely. Then I went into


That's where RIME holds your data EVEN IF you uninstall, so you must remove the whole "RIME" folder from


Since RIME doesn't come with Shuangpin installed, I had to go look for the schema(layout) on github (which is usually named 'double_pinyin' aka Shuangpin)

I found this one: https://github.com/kanlac/Rime-MS-shuangpin

Then I reinstalled. After reinstallation, I went into the settings and at the bottom of the settings box where it says "Control+grave" in the white field, I clicked the bottom underneath that said

獲取更多輸入方案 (Get more input schemes)

In the command prompt, I copied and pasted


and pressed enter and it automatically installed the correct Shuangpin layout for me

Then restart RIME so the new settings take effect

Lastly, all I had to do was go into the settings and deselect all the input methods that I am not gonna use, and only select 微软双拼 (Weiruan Shuangpin), then click 中 twice (once to finish the current window and the next to choose your color scheme)

edit: the picture attached below that says "simplified" just means the Title of the layout is in simplified format, but the actual way it is prioritizing the list when I type is now by Traditional edit: the picture attached below that says "simplified" just means the Title of the layout is in simplified format, but the actual way it is prioritizing the list when I type is now by Traditional

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.